Как создать имя в MS Excel. Виды и правила

Всем доброго времени суток! Решил начать очередной рабочий сезон (лето ведь сезон отдыха) статьей по редактору .

Есть в Excel такая полезная и интересная штука, как ИМЕНА. Во множественном числе потому, что они бывают разные, но основное предназначение у имен одно – упрощение составления формул и их читабельности.

Давайте посмотрим, каким объектам Excel можно присвоить имя:

  1. Имя ячейки: Коэффициент можно присвоить ячейки С5, в которой будет стоять некоторое число-коэффициент.
    =ПРОИЗВЕД(D5;C5) будет как =ПРОИЗВЕД(D5;Коэффициент)
  2. Имя диапазона ячеек: Доходзаполугодие можно присвоить диапазону D5:D60
    = СУММ(D5:D60) будет как =СУММ (Доходзаполугодие)
  3. Имя формулы Годовойоклад присвоено формуле =ПРОИЗВЕД(С2;12)
    =ПРОИЗВЕД(ПРОИЗВЕД(С2;12);1,25) будет как =ПРОИЗВЕД(Годовойоклад;1,25)
  4. Имя таблицы Сотрудники можно присвоить таблице, размещенной в диапазоне ячеек =Лист1!$A$3:$F$35
  5. Имя массива констант Массив1_10, можно присвоить диапазону чисел {1;2;3;4;5;6;7;8;9;10}.
    =ПРОИЗВЕД({1;2;3;4;5;6;7;8;9;10}) будет как=ПРОИЗВЕД(Массив1_10).

Обратите внимание на то, что массив чисел берется в фигурные скобки и записывается через точку с запятой.

Теперь не буду растекаться мыслью по древу, а перейду к основному — требованиям, которые должны соблюдаться при создании имени в редакторе Excel:

  • Имя должно быть лаконично и иметь смысловую нагрузку.
  • Длина имени – до 255-ти символов.
  • Пробелы не допускаются. В качестве разделителя можно использовать символ подчеркивания (_) или точку (.)
  • Имя может состоять из строчных и прописных букв, но Excel их не различает в именах.
  • Допускаются символы. Первый символ имени – буква, знак подчеркивания (_) или обратная косая черта (\). Остальные символы – буквы, цифры, точка и знак подчеркивания.
  • Нельзя использовать как имя буквы «C», «c», «R» и «r», так как они используются как имя строки и столбца.
  • Нельзя использовать имена в виде ссылок, а также такие специальные имена: Критерии, Извлечь, База_данных, Заголовки_для_печати, Область_печати.

Стоит обратить внимание на то, что все имена имеют определенную область действия. Это то пространство (лист или вся книга Excel), в пределах которого можно пользоваться конкретным именем. Так, если имя было создано с областью действия на Листе1, то при его использовании на Листе2 редактор Excel будет выдавать ошибку, а если имя создавалось с областью действия Книга, то имя будет действовать на всех листах.

Примеры использования имен были рассмотрены в начале статьи, а в следующей статье рассмотрим варианты создания (присвоения) имени в Excel.