Нумерация произвольных строк в Excel

Как пронумеровать в Excel смежные строки обычной таблицы мы уже ранее рассматривали в материале нумерация строк в Excel, а также как сделать нумерацию при помощи функции. А сейчас рассмотрим такой вариант — нумерация произвольных строк Excel.

Такая нумерация будет полезна при наборе документов с таблицами, имеющими строки-разрывы. Например, для отображения в таких строках заголовков, наименований групп товара или чего-то подобного. А реализуем мы всю эту красоту при помощи функции СТРОКА, с которой мы уже имели дело. Тут, как говорится, всё дело в нюансах.

Итак, повторюсь — функция СТРОКА используется для возврата номера строки.
Так, формула =СТРОКА(В1) возвращает значение 1, поскольку ячецка В1 располагается в 1-й строке.
При этом следует учитывать такие нюансы применения функции СТРОКА:

  • Когда аргумент функции не указан — СТРОКА(), то возвращается номер той строки, где размещена функция.
  • В аргументе указывается только один адрес ячейки.
  • Если в аргументе указать диапазон ячеек, а функция уже используется в вертикальном массиве, то функция вернет только нужные номера строк в качестве вертикального массива. Тоесть, формула {=СУММ(СТРОКА(B1:B3))} вернет значение 6, мотому что функция СТРОКА(B1:B3) вернет массив {1,2,3}(номера строк В1, В2, В3), а это 1+2+3=6.

Но сейчас не об этом, а о том, что данную функцию удобно использовать для автоматической нумерации любого вертикального диапазона, если предполагается частое добавление или удаление новых строк. Как говорил, это мы уже рассматривали.

Что же делать, если надо попрыкать номером по порядку между несколькими строками?

нумеруем несмежные ячейки

использовать массив А1, А2, ….., А как попало большое, но не больше чем нужно. 🙂

Что мы в итоге получим? А вот такое, условно, расположение функции в ячейках таблицы Excel и отображение соответствующих номеров:

=СТРОКА(А1)
=СТРОКА(А2)
=СТРОКА(А3)
некая строка
=СТРОКА(А4)
=СТРОКА(А5)
некая строка
некая строка
=СТРОКА(А6)
1
2
3
некая строка
4
5
некая строка
некая строка
6

Тоесть, разрывы могут быть разные и как угодно много, лишь бы при перепрыгивании не прерывался порядок А1, А2, А3 и т.д. За этим, конечно стоит следить отдельно, что поделаешь. Вот, пожалуй, и всё.

Как уже отмечал, можно обратиться к статье Автоматическая нумерация строк Excel с помощью функции.