Что же такое функция в Excel?

Zemanta Related Posts ThumbnailФункции представляют собой зависимость одного элемента (результата) от других элементов (аргументов,.. тех, что внутри :-)). Это как бы понятно. Для того чтобы использовать какую-либо функцию в , следует ввести ее как формулу (нюансы описаны тут) или как часть формулы в ячейку рабочего листа.

Последовательность, в которой должны располагаться применяемые в формуле символы и аргументы, называется синтаксисом функции. Все функции используют одинаковые правила синтаксиса. Если нарушить эти правила, то Excel выдаст сообщение о том, что в формуле имеется ошибка и не будет с вами дружить. Но поверьте, в функциях Excel все достаточно однотипно и разобравшись один раз, на одной-двух функциях, в остальных случаях все будет достаточно просто.

Правила синтаксиса при записи функций

Далее рассмотрены правила, которым необходимо следовать для грамотного и оптимального построения формулы с использованием одной или нескольких функций.

Если функция появляется в самом начале формулы, ей должен предшествовать знак равенства, как это имеет место в начале любой формулы. Я об этом уже говорил в предыдущих статьях, но не грех ещё повторить.

После этого вводится имя функции и сразу за ним – список аргументов в круглых скобках. Аргументы отделяются друг от друга точкой с запятой «;». Скобки позволяют Excel определить, где начинается и где заканчивается список аргументов.

Функция Excel

Функция Excel

Заметьте, в записи функции обязательно должны присутствовать открывающая и закрывающая скобки, при этом нельзя вставлять пробелы между названием функции и скобками. В противном случае Excel выдаст сообщение об ошибке.

В качестве аргументов можно использовать числа, текст, логические значения, массивы, значения ошибок или ссылки. При этом параметры, задаваемые пользователем, должны иметь допустимые для данного аргумента значения.

Например, в приведенной ниже формуле осуществляется суммирование значений в ячейках В2, В3, В4, В5 и Е7, причем часть ячеек — от В2 до В5, представлены как непрерывный диапазон.

Аргументы функции Excel

Аргументы функции Excel

Рассмотрим работу функции ОКРУГЛ(арг1;арг2), которая возвращает число, округленное до заданного количества знаков после запятой, и имеет два аргумента:

арг1 – адрес ячейки с числом (или само число), которое нужно округлить;

арг2 – количество цифр после запятой у числа после округления.
Чтобы округлить число 2,71828, находящееся в ячейке A1, с точностью до одного, двух или трех знаков после запятой и записать результаты вычислений соответственно в ячейки B1, C1 и D1, необходимо действовать следующим образом.

  1. Ввести число 2,71828 в ячейку A1.
  2. Ввести в ячейки B1, C1 и D1 формулы следующего вида:

=ОКРУГЛ(A1;1)

=ОКРУГЛ(A1;2)

=ОКРУГЛ(A1;3)

Аргументы могут быть как константами, так и функциями. Функции, которые являются аргументами другой функции, называются вложенными.

Например, просуммируем значения ячеек А1 и А2, предварительно округлив эти значения до двух десятичных знаков:

=СУММ(ОКРУГЛ(A1;2);ОКРУГЛ(A2;2))

Здесь функция ОКРУГЛ является вложенной аж два раза, но это не страшно, в формулах Excel можно использовать до семи уровней вложенности функций.

Стоит отметить, что в Excel существуют функции, которые не имеют аргументов. Примерами таких функций являются ПИ (возвращает значение числа π, округленное до 15 знаков) или СЕГОДНЯ (возвращает текущую дату). При использовании подобных функций следует в строке формул сразу после названия функции ставить пустые круглые скобки без аргументов. Другими словами, чтобы получить в ячейках значение числа p или текущую дату, следует ввести формулы такого вида:

=ПИ()

=СЕГОДНЯ()

Типы функций Excel

Для удобства работы пользователя при построении формул функции в Excel разбиты по категориям: функции управления базами данных и списками, функции даты и времени, финансовые, статистические, текстовые, математические, логические.

Текстовые функции используются для обработки текста, а именно: поиска нужных символов, записи символов в строго определенное место текста и т.д.

С помощью функций Даты и времени можно решить практически любые задачи, связанные с учетом календарных дат или времени (например, рассчитать число рабочих дней для любого промежутка времени).

Логические функции используются при создании сложных формул, которые в зависимости от выполнения тех или иных условий будут реализовывать различные виды обработки данных. Они особо интересны, и о них поговорим в отдельной статье.

В Excel широко представлены Математические функции и некоторые я уже привел в примерах.

В распоряжении пользователя также находится библиотека Статистических функций, при помощи которой можно осуществлять поиск среднего значения, максимального и минимального элементов и пр.